We're Experiencing Technical Difficulties

Incident Report for Century Tech

Resolved

This incident has been resolved.
Posted Aug 17, 2021 - 21:52 BST

Update

We are continuing to work on a fix for this issue.
Posted Aug 17, 2021 - 21:48 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 17, 2021 - 21:47 BST

Investigating

We are currently experiencing technical difficulties, the engineering team are aware and working to fix it as soon as possible.

We apologise for any inconvenience, we will send an additional update in 10 minutes.
Posted Aug 17, 2021 - 21:42 BST
This incident affected: CENTURY Tech - Application.