We're Experiencing Technical Difficulties

Incident Report for Century Tech

Resolved

This incident has been resolved.
Posted Feb 07, 2024 - 09:28 GMT

Update

We have identified the issue and are working on a resolution, we'll update in 5 minues.
Posted Feb 07, 2024 - 09:17 GMT

Identified

We are currently experiencing technical difficulties; the engineering team are aware and working to fix it as soon as possible.

We apologise for any inconvenience, we will send an additional update in 5 minutes.
Posted Feb 07, 2024 - 09:09 GMT
This incident affected: CENTURY Tech - Application.