CENTURY Service Disruption

Incident Report for Century Tech

Resolved

We are continuing to monitor for any further issues.
Posted Feb 27, 2023 - 14:12 GMT

Update

We are continuing to monitor for any further issues.
Posted Feb 27, 2023 - 13:59 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2023 - 12:58 GMT

Update

We are continuing to investigate this issue.
Posted Feb 27, 2023 - 12:19 GMT

Investigating

We are currently experiencing a service degradation.

Our engineering team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Feb 27, 2023 - 11:56 GMT
This incident affected: CENTURY Tech - Application and CENTURY Tech - API.