Assignments - Schools

Incident Report for Century Tech

Resolved

This incident has been resolved.
Posted Sep 13, 2024 - 12:04 BST

Monitoring

We are aware that some of our school users have experienced issues when using our new Assignments feature. After working to fix this we do not expect further disruption, but we continue to monitor closely. This only affects organisations and there is no impact for customers on our Core or Bond plans.
Posted Sep 12, 2024 - 21:28 BST